94 kx 125 no powerband

Discussion in '2-Stroke Discussion' started by cowasucky, Mar 16, 2012.



  1. cowasucky

    cowasucky Rookie DRN Member

    Joined:
    Feb 23, 2009
    Messages:
    170
    Likes Received:
    0
    Trophy Points:
    0
    I got the bike running pretty good so I thought...it starts up on first kick, good compression, but just bogs when powerband should hit. Ive just put new pro series reeds, new air filter and new plug in, new throttle cablle and cleaned the carb thoroughly. All I can figure is power valve ? Can I clean it without having to remove it....like just take off the cover and boot ??? If so, with what and if not how ?? Lol..... and YES I do have a manual lol.....

  2. arnego2

    arnego2 Member DRN Member

    Joined:
    Mar 8, 2008
    Messages:
    272
    Likes Received:
    1
    Trophy Points:
    18
    Bogging is a sign of too lean, how do you set up the carb after changing the reeds?
  3. cowasucky

    cowasucky Rookie DRN Member

    Joined:
    Feb 23, 2009
    Messages:
    170
    Likes Received:
    0
    Trophy Points:
    0
    I left it the same...maybe bogging is not the right word. When it revs to the point that the powerband should kick in....it just doesnt, thats it. Its still reving high, just not going any faster. It cranks right up and seems to do "ok" till that point. So , as far as jetting goes, would that be the clip position ???
  4. arnego2

    arnego2 Member DRN Member

    Joined:
    Mar 8, 2008
    Messages:
    272
    Likes Received:
    1
    Trophy Points:
    18
    needle

    The needle setting is good from about 1/4 to 3/4 of throttle. [​IMG]


    Where is your jetting at? Needle clip sits in upperst (first) or second upperst position? If you are not in the lowest clip postion go one deeper. That enriches the mixture.

    The powervalve is hard to clean on the bike better take of the cylinder and proceed from there. Can't you take off the side cover and rev the bike on a stand? You should see some movement.
  5. cowasucky

    cowasucky Rookie DRN Member

    Joined:
    Feb 23, 2009
    Messages:
    170
    Likes Received:
    0
    Trophy Points:
    0
    Clip is in middle position..new update !!!!!! I noticed a worn area in the upper corner of the carburetor slide. That could cause the rich condition ? I'm really frustrated with it cuz it rides great...strong in the low end .....there just is no powerband, which why I ride a 2 stroke lol..... I will finally have some time the next few days to check it out more. How do I check the powervalve? Do I remove the covery and boot from the governor or the cover on the front of the cylinder ? Then what ? Rev it high rpms ? What do I look for ? What should I see ?
  6. arnego2

    arnego2 Member DRN Member

    Joined:
    Mar 8, 2008
    Messages:
    272
    Likes Received:
    1
    Trophy Points:
    18
    Powervalve should work smooth and without any hook ups when disconnected. I fear yiu have to pull your jug to work on the PV. By the way how old is your top end?
  7. Oldman125

    Oldman125 Rookie DRN Member

    Joined:
    Jul 1, 2006
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    0
    You should be able to remove a small grey plastic cover on the right side of the cylinder that covers the power valve slider (I don't know what to call it) You can run the engine with this cover off and when reving it up you should see movement in and out. If not something is stuck, broken or misadjusted.This shaft operates two side doors and the main flapper which you can see when looking in the exh port with the pipe off. The ramp and cup (governor asmy) is under the main clutch housing (side cover) should you need to remove it. Make sure none of the parts are gummed up and sticky or broken. Your best bet is to find a parts diagram: http://www.google.com/search?tbm=is...669.0.9915.22.22.0.15.15.0.63.415.7.7.0.llsin.
    Study it and learn how everything functions.


    The worn carb slide will create a lean condition....worn slides are very common. You can search for a nice used one or just buy a new one. Make sure the cutout is the same number (located on the angled part on the bottom) or if you know what you are doing you can change this along with other facets of the jetting to create different running characteristics. This is advanced tuning. Above all, make sure the jetting is correct after everything functions properly and all the parts are in good order. The engine should have a crisp "bin bin ba bin bin bin" idle with the air screw out about 1.5 to 2 turns. More and the pilot is too rich, less and it's too lean. At part throttle under light load (needle) it should have a tight sputtering sound and under a load (main) it should pull hard in a smooth acceleration with no hesitation, no blubber and no ooz out of the tail pipe...as long as you ride it hard enough to keep it hot and cleaned out. 32:1 works well for a track ridden 125.
    As you roll on the throttle it should be a wave of power along with the hit you're searching for with no bogs or sputts. Use NGK plugs..the standard or V-Power are fine. Don't use anything else. Make sure the reeds are closed and there are no frays or chips. Make sure there are NO air leaks. A little brake cleen works well for this or if you suspect leaks have it pressure tested. Make sure the cylinder bore and piston/ring are in good shape and not worn out.
    The carb has to be tuned properly to get the most out of a 125; and this takes some skill and lots of seat time to get just right. Hope this helps.
    Let us know how it goes!
  8. BSWIFT

    BSWIFT Sponsoring Member<BR>Club Moderator N. Texas SP

    Joined:
    Nov 25, 1999
    Messages:
    8,196
    Likes Received:
    5
    Trophy Points:
    38
    Well spoken (worded).:)
Similar Threads: powerband
Forum Title Date
2-Stroke Discussion rm 125 powerband issue Oct 10, 2010
2-Stroke Discussion wider powerband Mar 13, 2010
2-Stroke Discussion rm 250 powerband problems May 4, 2009
2-Stroke Discussion Powerband not "hitting right". Nov 22, 2008
2-Stroke Discussion powerband and powervalve problems??? Sep 24, 2008

Share This Page