Cdi Rmx250

Joined
Jan 27, 2013
Messages
37
Likes
0
#1
Hey people been awhile since ive been on. Is it possible for a cdi to be alittle bit faulty? Reason im asking is....my bike runs,idles well....but under load it runs like dog sh**! Ive tested the cdi stator and coil....stator n coil ohm out per manuals specs. The cdi on the other hand has readings that or either very high or extremely low in comparison to manuals ohm spec. On another forum...a member says you cannot ohm test a cdi....it has to be diode tested...does anybody no if this is true? Also, does anyone know if an rm cdi will work in rmx? If so, will it affect rideability anyway? One more thing....if anyone has an extra cdi lying that i could use just for testinv purposes thatx be fantastic. Thanks tony
 

motometal

Lifetime Sponsor
Joined
Sep 3, 2001
Messages
2,682
Likes
3
#2
Many times if ignition components are bad, the problem is intermittent such as the problems kick in when the engine gets warm or under a load. Could be the ignition is not the problem but one thing you could do is buy a CDI off Ebay and if that doesn't fix it, resell. Or if you can find a buddy with the same bike...

Those were great bikes, especially once you installed aftermarket exhaust and jetted them.
 

jaguar

Subscriber
Joined
Jul 29, 2000
Messages
1,431
Likes
62
Location
South America
#3
the main charge capacitor or SCR can be going bad. When this happened to my CDI I took it to someone who repairs them and he replaced them both and it worked again. But that's here in south america. In 1st world countries everyone is expected to buy new and so no one repairs them. But you can try it yourself. The generic parts are listed on my page: http://www.dragonfly75.com/moto/CDI.html