High rpm in every gear

Joined
Jun 18, 2019
Messages
3
Likes
1
#1
My bike ran perfectly fine since I have had it, so good it was hitting power band even in 1st gear. I wrecked the other day broke the clutch lever and the throttle cable replace both myself. Now bike idle just fine but when I put it in gear and start to ride it revs to super high in every gear. No time to ride in any gear just straight to high rev sounds like I'm at the rpm Max and not changing my gears. I checked the Reed it looks fine. There's no tension on the throttle cable and needle sits correct in the carb.. someone told me the water pump.. I'm out of ideas
 
Joined
Jul 27, 1999
Messages
22,541
Likes
352
Location
Chicago
#2
You just changed the throttle cable and now the throttle is sticking open. Seems like a good time to retrace your steps and verify the carb needle isn't getting hung up or the cable isn't getting caught somewhere in it's path.
 
Likes: The Redrider
Joined
Jun 18, 2019
Messages
3
Likes
1
#3
I took the seat and gas tank off to make sure it didn't get caught on nothing ran it close as I could how it came factory..I lube the cable before installing it. I can hear the needle tapping the bottom of the carb when I twist the throttle.
 
Joined
Jun 14, 2019
Messages
89
Likes
11
#4
When ever I install a new cable I route it in the same factory area, I verify that its the correct one, then I fire up my scoot and with the tank off, I move my handle bar left and right to see if the rpms pick up.
 
Joined
Jun 18, 2019
Messages
3
Likes
1
#5
I did that too.. a riding buddy of mines told me to check the power val it might had mess up when I wrecked because the bike not giving out power like it was and the reason it sound like it red lining
 
Likes: The Redrider
- a d v e r t i s e m e n t -

Joined
Jun 14, 2019
Messages
89
Likes
11
#6
I did that too.. a riding buddy of mines told me to check the power val it might had mess up when I wrecked because the bike not giving out power like it was and the reason it sound like it red lining
May be an air leak, lean conditions could be the culprit. Check for air leaks, do a leak down test, you tube will show you the way!
 
- a d v e r t i s e m e n t -