RFS Clutch Protector Problem

Joined
Nov 28, 2000
Messages
56
Likes
0
#1
I bought a billet aluminum clutch slave protector for my 01 400 m/xc and it doesn't seem to be designed to fit with the stock aluminum rail above the chain, it appears to be about 1-1/2 mm to thick on that corner. When installed the clutch slave would flex and leak at the bottom. I wont say the name yet as I haven't contacted the manufacturer. Has anyone else had this problem?
BENT

------------------
01 KTM400 M/XC
98 FMF CR125
01 CR80
00 XR50
 
- a d v e r t i s e m e n t -

jeb

Member
Joined
Jul 21, 1999
Messages
633
Likes
0
#2
Sounds like you got the wrong part. I have two models of that protector from EE. One on my 99 250E is flat on the outward surface. The one on my 01 400E has clearence for that rail above the chain.

I just looked at the website ( http://www.enduroeng.com/protection.htm ) and they don't show the exact model. They do have a 'new lower' price though.

------------------
John Brunsgaard - JEB
01 KTM 400 EXC, 99 KTM 250 EXC, 99 KTM 200 EXC, 98 KTM 125 EXC, 98 KTM 380 MXC (gone), 96 KDX 200

[This message has been edited by jeb (edited 04-13-2001).]
 
Joined
Mar 19, 2001
Messages
196
Likes
0
#4
Mine for my 400EXC also came from erider. It fit perfectly. I had another brand laying around the garage. It wouldnt fit. But the Erider one was a perfect fi.

------------------
 
Joined
Nov 28, 2000
Messages
56
Likes
0
#5
Well I got out the caliper and after measuring everything I decided it was my installation error. It just requires a very specific alignment. I am not excited about how hard it was to tighten the bottom bolt but it seems to be solid now. Thanks for your input.
BENT

------------------
01 KTM400 M/XC
98 FMF CR125
01 CR80
00 XR50
 
- a d v e r t i s e m e n t -