FUNDRAISER!
We need to cover DirtRider's expences
for the next year.
Every little bit helps!



Help 04 Cr85 main jet problem!

Sep 10, 2018
3
0
#1
So in April I bought an 04cr85, for a while the thing ran perfectly, over time it started to lose top end power, a bit from the piston wearing down, and a bit of a sputter from running too rich. I'll start off by saying bottom end rpms run fine since I got the bike till now. But I recently rebuilt the top end, hoping it would fix the problem, yet the engine still sputters in the top end. I have a stock 125 main jet. And purchased the next size down, a 122 main jet. The 122 main jet runs noticeably too lean. And I cant get the bike to have a smooth powerband with either,, first time writing on a forum so any help would be appreciated. Hopefully I can get a vid of how the bike runs up soon
 
Sep 10, 2018
3
0
#3
If you change the main you want to also look at the pilot and the needle so things transition smoothly.
Pilot jet runs fine tho, I'm starting to think it could be reeds because I can hammer the throttle in the bottom rpms no problem bike just doesnt want to go into the powerband, has a fresh piston,rings, and gaskets too. But the bike is also fouling plugs so idrk rn
 
A: The best deals from every major mx dealer, right here.
- a d v e r t i s e m e n t -

Sep 10, 2018
3
0
#6
what oil you using and at what fuel/oil ratio?
make sure your air filter is clean and that the pipe stinger isn't carboned up and restricting flow at high rpm. If you suspect that then take the pipe off, put pebbles in it, and shake it a lot.
I'm using standard 2stroke oil non-synthetic at 32-1 and I clean my carb and air filter often so it could be the pipe. Gonna watch a vid and attempt to clean that now I'll let you know after
 
A: The best deals from every major mx dealer, right here.
- a d v e r t i s e m e n t -