stejh311

Member
Apr 5, 2019
2
0
Very hard to kick start. Used to start right up, now takes a long time, lots of kicks.
Once started it idles fine with the choke on, but revs HIGH when choke is off.. I've played around with the idle screw, but didn't make much difference. Thought maybe a possible air leak? But couldn't find one.
Thoughts? Advice?
Think I'm gonna clean the carb and jets, and replace the spark plug. And give it another go...

Any advice welcomed!
Thanks!
 

nathanlayland

Member
Mar 31, 2021
3
0
Im having the same issue except my bike starts no problem. So far youre the only person with this problem ive seen. Have you happened to figure out the problem yet?
 

RM_guy

Moderator
Damn Yankees
LIFETIME SPONSOR
Nov 21, 2000
6,951
179
North East USA
Im having the same issue except my bike starts no problem. So far youre the only person with this problem ive seen. Have you happened to figure out the problem yet?
2 stroke or 4 stroke? If it idles fine with the choke on and revs high with it off, you have a very lean condition and if this is a new problem and you have an air leak someplace. The only way to test for a leak is to do a leak down test. It can be a leak that you can't see, like a leaky main crank seal on a 2 stroke.
 

nathanlayland

Member
Mar 31, 2021
3
0
2 stroke or 4 stroke? If it idles fine with the choke on and revs high with it off, you have a very lean condition and if this is a new problem and you have an air leak someplace. The only way to test for a leak is to do a leak down test. It can be a leak that you can't see, like a leaky main crank seal on a 2 stroke.

Yea its a 1999 yz250. I think it may be the pilot jet so i will try that first but if not i will do a leakdown test and replace seals if needed
 
Top Bottom