PlowboysGhost

Member
Nov 19, 2007
18
0
It's a little difficult to start, loads up terribly at idle-to half throttle, clears up in the upper revs (where it sounds good and pulls good), smokes wayyy too much until the upper revs, blows oil spooge on everything up to 12ft. away(and I mean a LOT!)cars/lawnmower/my helmet.

It's on Golden Spectro @32:1(which alone has never caused these symptoms in any other machine I've had), new reeds, clean carb, fresh top-end, new air filter.

I suspect a leaky right side crank seal, though I have no other way to test it than to take the oil filler plug out(has no positive or negative pressure when running), and put a little soapy water into the right side cover vent tube(hardly inflated or deflated a soap bubble).

Any ideas?
 

2strokerfun

Member
May 19, 2006
1,500
1
Are you losing transmission oil?? If you are, seal is likely culprit. If not, then it probably isn't. Sometimes the needle jet and jet needle on older carbs have some wear and need to be replaced. But first, I would start with jetting. Might have too rich of pilot and needle may be set too high.
 

PlowboysGhost

Member
Nov 19, 2007
18
0
I am losing transmission oil, so I'm thinking right crank seal or center case seal now.

It's got the stock size #55 pilot jet and the needle's clip is on the stock(spec) 3rd groove. I thought jetting/carb issues were the culprit until after losing about 1/3 my tranny oil in 5 minutes of run time.
 

PlowboysGhost

Member
Nov 19, 2007
18
0
Someone(idiot) had dobbed about a half tube of RTV into the right crank seal.


All will be right this weekend.
 
Top Bottom