BillyWho, Broken Cable On My Brace I Need Your Help

Joined
Jul 3, 2002
Messages
21
Likes
0
#1
Hi BillyWho, I talked you a few months back about sizing etc on the braces. I love my Asterisk's I wouldn't ride without them. Now that's my problem lol. I have had these braces for not even 6 months and the cable on the Left brace has snapped. I never even noticed it until I was putting them on before my race. I'm guessing I will need to send them down to you to get fixed? I looked at the other cable and it kind of looks like that one could be rubbing to. There is a coating over the cable and it looks like it has woren through the coating. Is there a fix for this problem or is this normal ware?
Because it looks like I need the new cable along with a new adjuster. I have some good close up pics of my brace if you would like to see them.
Thanks BillyWho
yz007f
 

oldguy

Always Broken
Joined
Dec 26, 1999
Messages
9,422
Likes
0
#2
I get to play Billy here :aj:
Call Asterisk and have them send you the updated cables. once you get them it takes about 10 minutes to do the first and then just a couple to do the other 3. If you have trouble getting in contact with them email me and I can send you a new set
 

BillyWho

Sir-Breaks-Alot
Joined
Mar 22, 2001
Messages
1,828
Likes
0
#3
Yeah, what he said lol. The number is 800-459-2999, talk to Laury or Brad, they'll send the repair kit right out. Let me know how it turned out. The new cables are fiber, so you won't have this problem anymore.
 
Joined
Jul 3, 2002
Messages
21
Likes
0
#4
Thanks guys!
I will phone Monday morning and get them to send me a new set of cables. I love these braces so much I'm still riding with the broken cables lol. Because I couldn't be without them.

Thanks again!
yz007f