Cdi Rmx250

Joined
Jan 27, 2013
Messages
37
Likes
0
#1
Hey people been awhile since ive been on. Is it possible for a cdi to be alittle bit faulty? Reason im asking is....my bike runs,idles well....but under load it runs like dog sh**! Ive tested the cdi stator and coil....stator n coil ohm out per manuals specs. The cdi on the other hand has readings that or either very high or extremely low in comparison to manuals ohm spec. On another forum...a member says you cannot ohm test a cdi....it has to be diode tested...does anybody no if this is true? Also, does anyone know if an rm cdi will work in rmx? If so, will it affect rideability anyway? One more thing....if anyone has an extra cdi lying that i could use just for testinv purposes thatx be fantastic. Thanks tony
 

motometal

Lifetime Sponsor
Joined
Sep 3, 2001
Messages
2,682
Likes
3
#2
Many times if ignition components are bad, the problem is intermittent such as the problems kick in when the engine gets warm or under a load. Could be the ignition is not the problem but one thing you could do is buy a CDI off Ebay and if that doesn't fix it, resell. Or if you can find a buddy with the same bike...

Those were great bikes, especially once you installed aftermarket exhaust and jetted them.
 

jaguar

Subscriber
Joined
Jul 29, 2000
Messages
1,439
Likes
70
Location
South America
#3
the main charge capacitor or SCR can be going bad. When this happened to my CDI I took it to someone who repairs them and he replaced them both and it worked again. But that's here in south america. In 1st world countries everyone is expected to buy new and so no one repairs them. But you can try it yourself. The generic parts are listed on my page: http://www.dragonfly75.com/moto/CDI.html
 
Joined
Jan 3, 2020
Messages
10
Likes
1
#4
Hey people been awhile since ive been on. Is it possible for a cdi to be alittle bit faulty? Reason im asking is....my bike runs,idles well....but under load it runs like dog sh**! Ive tested the cdi stator and coil....stator n coil ohm out per manuals specs. The cdi on the other hand has readings that or either very high or extremely low in comparison to manuals ohm spec. On another forum...a member says you cannot ohm test a cdi....it has to be diode tested...does anybody no if this is true? Also, does anyone know if an rm cdi will work in rmx? If so, will it affect rideability anyway? One more thing....if anyone has an extra cdi lying that i could use just for testinv purposes thatx be fantastic. Thanks tony
Maku sure there isnt any leaks in the intake manifold, you can test it by spraying starting fluid around it while running and see if it revs up. If it isnt in the intake, try preheating your oven to 300 degrees F, turn the oven off and place the CDI in the oven and leave it in until it cools. They usually start giving you trouble because moisture got in it. I would do that a couple times before purchasing a new one. I can make you a harness that will let you use the generic 6 pin CDI boxes for around $40. I have a 96 RMX 250 and I havent had any issues using a cheap chinese CDI