RECENT POSTS

gas and spark, but no fire, what next ?

Joined
Dec 16, 2006
Messages
86
Likes
0
#1
I own a 1981 yz250 It gets fuel to the spark plug and has good spark but it won't fire or start. what should I check next? and how do I check my timing?
 
Joined
Dec 16, 2006
Messages
86
Likes
0
#4
Mouse nest

It does have plenty of compression, but upon further investigation I found a mouse nest inside my expansion chamber. which I cleaned out. I did get it to run but with ether (aka starting fluid) sprayed directly into carb . but I could not get it to start or fire on the gas from the tank which is fresh mix.
 
Joined
Oct 19, 2006
Messages
2,142
Likes
1
#5
If it runs on ether but not without, you're not getting fuel. Open up the carb and really clean it. Remove the jets and blow them out. Blow out all air passages. How plugged is the air filter?
 
Joined
Dec 16, 2006
Messages
86
Likes
0
#6
Air filter was taken off prior to starting.

I should also point out as it ran on ether it ran a very high rpm is this normal when you spray ether directly into carb.
 
Joined
Apr 26, 2007
Messages
147
Likes
0
#7
cleopatrisha said:
I should also point out as it ran on ether it ran a very high rpm is this normal when you spray ether directly into carb.
Yes, because there's nothng metering it. Keep in mind that when running on either the motor isn't getting any lubrication :yikes:. Follow GMC's advice and clean the carb thoroughly. Also be sure your air filter is clean and freshly oiled before taking it out for a ride.
 
Joined
Dec 16, 2006
Messages
86
Likes
0
#8
Thanks for all comments

I cleaned the carb well accually I had my lawnmower repairman friend help me and it runs great now he also adjusted the float. the carb definitaltly needed cleaning. again thanks.