Need some advive

Joined
Jul 2, 2007
Messages
7
Likes
0
#1
I have a 1988 kx 250 which at end of last summer I installed a new piston & rings (stock bore) I checked bore and was within tolerance. My problem is at full throttle its sputtering. I know the main jet controls this but cant understand why it would need changed as its same bore size and nothing else has been changed on bike. I tried changing the jet needle clip position but didnt help much. I put it back at #3 position for now. I am getting an exhuast leak (oily around flange) but other than that I dunno.When I put in the new piston I cleaned the exhaust valves out completely unless they might have gummed up since then. The bike is very cold blooded to start but runs fine at everything but full throttle once running. Any help would be appreciated. Thanks
 

WoodsRider

Sponsoring Member<BR>Club Moderator
Damn Yankees
Joined
Oct 13, 1999
Messages
2,812
Likes
0
#3
Oil around the flange is a sign the o-rings at the pipe to cylinder connection need to be replaced. Make sure you are using fresh gas premixed at 32:1 or 40:1 with a quality synthetic or semi-synthetic oil before doing a WOT plug reading. If it's too rich, put the clip in the top groove and do another WOT plug reading. If this shows some improvement, go with a 1 size smaller main jet and return the clip to the middle position. Keep doing WOT plug readings until you have the correct main jet.
 
Joined
Jul 4, 2007
Messages
11
Likes
0
#5
if the main doesnt help try a hotter spark plug wondering if you put a different plug in it when it was rebuilt?