Problems with my 96

Joined
Jun 19, 2002
Messages
88
Likes
0
#1
At first I thought my bike was running good, but now that I have a little more riding experience I can tell that its not. In fact its not revving out at all. It has a FMF Fatty Gold Series, a turbine core spark arrestor, and a boyeson rad valve. The guy I bought it from said it had been rejetted but Im not so sure. It runs pretty good in the lower rpm's, but it then it just stops pulling. I tried a new plug which helped out some, and cleaning the air filter helped a little also.

You guys have any thoughts?

Thanks,
Joey
 
Joined
Jun 19, 2002
Messages
88
Likes
0
#3
Sorry for the long wait on this post. The last couple days have been really difficult for me because the loss of a friend.

I use a NGK B8ES plug. I am not sure on how to tell what the bike is jetted at now. I run Golden Spectro 40:1. I think this winter I am going to go 225cc with it and maybe have a little porting done. After that I can get the carberator tuned perfectly for it.

I will check buykawasaki.com now.

Thanks,
Joey
 
Joined
Jun 19, 2002
Messages
88
Likes
0
#5
I guess I will do that then. The jets just unscrew right? Sorry I am all new to this but I am not afraid to try it out. I'll check that later tonight and get a baseline. I think whoever jetted it richened it up way to much because my plug is black. I think the pilot jet is fine because it runs good off the bottom but then just stops pulling and wont rev out when you open it up. You are probably right about the power though. I think it will have enough for me once I get it running good.

Thanks,
Joey