RECENT POSTS

white residue on inside of oil level guage glass

Joined
Apr 19, 2003
Messages
488
Likes
0
#1
anybody ever get this? white residue on inside of oil level gauge glass. it wasnt there before todays ride. after about 2hrs i noticed something white on the inside of the glass. it didnt move with the oil as i rocked the bike back and forth? could barely see the oil level but could see it. i run it at the top of the glass and i havent changed oil brands or anything. drained the oil when i got home and there was no water in it. the oil looked fine. thanks
 

Y2Z

Subscriber
Joined
Apr 6, 2002
Messages
411
Likes
0
#2
my 89 does that too, i think its just moisture, it goes away when the bike sits for a bit
 
Joined
Apr 19, 2003
Messages
488
Likes
0
#4
its not in the oil cz its a white residue on the inside of the glass itself. oil looked good.
 
Joined
Apr 19, 2003
Messages
488
Likes
0
#7
i think im going to change the oil seal on the water pump shaft just to be safe. is there anything else i should check or replace besides this?
 

speedyts49

Subscriber
Joined
Jul 4, 2002
Messages
112
Likes
0
#8
I had a simular problem, drained and checked the oil and saw no coolant. I repeated this and still I could not see anything in the oil. I changed the seals and the problem went away. I always thought that oil floated on water and you would see the difference but it seems they do mix too some degree.
The seal replacement is a pretty easy one and should fix your milky glass.
tom
 
Joined
Apr 19, 2003
Messages
488
Likes
0
#9
thanks tom. you mentioned seals, i only saw one that looked like it would need to be changed on buykawasaki.com parts diagram. which seals did you change?
 

speedyts49

Subscriber
Joined
Jul 4, 2002
Messages
112
Likes
0
#10
I recall replacing a couple of items. I'd ask the parts guy to be sure. I have also heard of the shaft being damaged (scored) and I think you can use some emery cloth on it if it is not too bad. Mine was just a bad seal. Do a search for more info on this.
good luck,
tom