Newbie advice

Discussion in 'Women's Forum' started by dirtygirl23, Jun 4, 2014.

  1. dirtygirl23

    dirtygirl23 Rookie
    Member

    Joined:
    Apr 6, 2013
    Messages:
    3
    Likes Received:
    0
    Hey ladies,



    So I'm a total newbie and am simply trying to put a new chain on my bike, 2003 TTR125 L. The old chain was NOT an "o ring" chain, and supposedly neither is the new one. I have the back plate with the attached pins, the front plate, and the clip. Why is there so much play between the front plate and the clip? I must be missing something. Thanks
     
  2. Okiewan

    Okiewan DRN is my fault.
    Staff Member

    Joined:
    Dec 31, 1969
    Messages:
    28,292
    Likes Received:
    8,382
    Anyway to take a picture of the gap? Some play is normal.
     
  3. rmc_olderthandirt

    rmc_olderthandirt Subscriber

    Joined:
    Apr 18, 2006
    Messages:
    1,534
    Likes Received:
    8
    It sounds like the master link is not compatible with the chain. Did the master link come with the chain, or were they purchased separately?

    I have always gotten a new master link along with a chain and then they should match.

    There shouldn't be any gap between the plate and clip. If there is, something is wrong.

    If it was an O-Ring chain and you managed to drop the O-rings out that could account for the gap. Look around and see if there are four little tiny doughnut looking things lying about.

    Rod
     
    Okiewan likes this.

Share This Page