what the...

Joined
Dec 29, 2000
Messages
22
Likes
0
#1
Last week when i rode my bike and it ran just fine but then yesterday i went out to ride and it ran like crap. when i started it up it sounded like the throttle was wide open, so i thought the throttle might be stuck. it wasn't and niether was the carb. needle. could my jetting be off, making the engine run hard? i don't know a whole about carb. jetting. also, i messed with the idle and nothing changed. thanks for the help.
if it makes any differance i have a '97 yz 125.:(
 
Joined
Jan 27, 2000
Messages
6,959
Likes
42
#2
charger.

Sounds like you may have an air leak. Could be the crank seal on the left side or a leak in your intake manifold or base gasket. Take some WD40 and spray it around the manifold gasket and base gasket while the bike is running. If one is leaking, you should be able to see bubbles or the WD being sucked in to the gasket area.

Just my $.02
 

smb_racing

Master of None
Joined
Jul 31, 2000
Messages
2,085
Likes
0
#3
sounds like you've got a piece of dirt lodged in your pilot jet, I'd recommend cleaning the carb thoroughly and then trying it again with fresh gas.
 
Joined
Jan 27, 2000
Messages
6,959
Likes
42
#4
charger.

Forgot to mention one thing. If your rpm goes down while you are spraying the WD40, then, chances are it is a gasket leak. You can't always see the WD being sucked in to the gasket, but, if the rpm changes, that is a good indication that the gasket is leaking.

Ok, now we're up to $ .04