just_a_rider

Member
Jul 25, 2006
394
1
The machine is my boys an is an 02. I know it's not a dirt bike but it does have a 9:1 compression 4 stroke on it. The darn thing is spuddering like it's running out of feul, I've reset the float to a higher possition to let more feul in the bowl but still after a hard lap it's still running out. I've also checked every thing and cleaned every thing so nothings stoped up. I run high octane in it. Any advice would greatly be accepted.
 

Rich Rohrich

Moderator / BioHazard
LIFETIME SPONSOR
Jul 27, 1999
22,820
16,889
Chicago
A good place to start would be to unhook the fuel feed line to the carb and measure the flow from the tank. It sounds like the vent in the cap might be plugged or the petcock screen is restricted and stopping the flow of fuel.
 

DieselTech

Always breakin' something
~SPONSOR~
Jan 21, 2007
109
0
Also, you may want to reset the float back to stock specs, unless that's what you did already. You shouldn't just go arbitrarily change the float setting "just because". Did it always run like this? Have you checked all the basics (spark plug, air filter, etc.)? I own 2 of these machines (well, 1 used to be a 50 that I stuffed an 80 motor into) and they are pretty darn reliable if you maintain them properly. Hope that helps.
 

just_a_rider

Member
Jul 25, 2006
394
1
My wifes aunt and uncle just got this thing for him. An 02 for 900 and has barely been rode, thats the whole thing there, it would only run on choke when they got it down here because it had been setting for so long so I tore the carb down and cleaned it and it ran fine untill you put a hard ride on it. The flow seems good but I failed to check the vent cap, I'll give that a try thanks for the help.
 
Top Bottom