RECENT POSTS

clutch problem

Joined
May 22, 2007
Messages
4
Likes
0
#1
i recently took most of my bike apart (besides the tranny and clutch) and clean it all out cuz i had to replace a broken exhaust valve neway...but now that i have put it all back together (besides a few parts), when i pull the clutch lever in its staying in unless i push it back out...i didnt take the clutch apart but i did remove the clutch cover to repaint it...cant figure out wat i did wrong....any help would be appreciated, Bill
 
Joined
Jun 30, 2006
Messages
145
Likes
0
#3
well that means that you might have eather a pinch in the cable, or maybe the cable is stretched to far from excessive wear, or maybe you didn't put it back together properly. how exactly did you take it apart?
 
Joined
May 22, 2007
Messages
4
Likes
0
#4
all i did was remove the clutch cover and remove the handle bars(things i did that involved clutch) but im gunna see if there is nething wrong with the line, but besides that i dont kno wat could have hapend
 
Joined
Jun 30, 2006
Messages
145
Likes
0
#5
yea me eather, my best guess is that you have a pinch, or bend in the clutch cable.
-Tony #422
 
Joined
May 22, 2007
Messages
4
Likes
0
#7
i think i might know the problem but im not an expert with clutches so i dont know....i just took off my clutch cover and the little round thing with the threads on one side of it that sticks out has alot of play, not just in and out but up/down/side to side too, does the little clip ("C" shape with a hole on each end) go on the inside or should i be able to see it?