MXer666

Member
Jul 15, 2007
75
0
hey ive got a 84 cr125 and i can no longer get it started. When i first got it i had it resleeved, new top and bottom end, new bearings and seals all way around and it has about 15-20 hours on it. I run it 32:1 with motul.

so my problem is this, 2 months ago i wasnt getting any spark at all, ruled it out to be a faulty stator cuz my manual specified for a 98 ohm reading and i was getting over 200 ohms. everything else(CDI, Ignition coil) have been replaced with good working units. So i ordered a new stator from rickystator.com and it came in last thursday and i put everything back together. The spark looked really big and blue and friday night i finished everything and stated it in about 3 kicks. I went for an hour ride came back parked the bike and went to it the next day and it wouldnt start. I baught new spark plugs still wont start. Checked to see if it was flooded by turning the bike upside down and it was fine. So really im just looking for ideas on why it wont start now when it did a cupple of days ago. Ive checked the wiring and it all looks good, i checked reading of the coils and there also good. Im going to replace my CDI with another one tommorow cuz right now im sick of taking everything off.

Throw me a line if you have any suggestions, i really want to ride ive been without a bike for 2 months now and its killing me.
 

MXer666

Member
Jul 15, 2007
75
0
ya ive completely disconnected it. As well i forgot to mention, i am currently getting a spark but its not that big, do you have to adjust the timing when you replace your stator?
 

mideastrider

~SPONSOR~
Jul 8, 2006
827
1
You didn’t mention anything about the pulser but I don’t know if that would make a weak spark though. I had one go bad and the bike would run about 20min start missing and go dead and wouldn’t start back until it cooled. Have you changed to a different plug cap or did you take the plug cap off the old coil they can cause problems. Electrical problems can be a pain to diagnose.
 

MXer666

Member
Jul 15, 2007
75
0
ya ive switch many plug caps and ignition coils. the pulser reads within specifications as well.

keep em comming im open for more ideas.
 

j.lawson

Member
Jul 18, 2007
78
0
Yes you may have to time your bike. possibly your flywheel lost magnetism? I dont know? Just check all your electrical things, thats an old bike. Exciter coil? pulse generator? coil? whatever? If it's getting spark then check your time. If it's weak spark, check your cap, and wire, stuff mentioned above ^^. Good luck bro. Hard to tell over the internet.
 

BSWIFT

Sponsoring Member
N. Texas SP
LIFETIME SPONSOR
Nov 25, 1999
7,920
42
Have you checked your reeds? Air filter? Case seals? Ground wire? I work with electronic systems daily and meter readings help with most everything I do. However, sometimes it just takes trial and error or pure dumb luck to find the problem. You have centered all of your questions on the electrical parts but there is more to your engine than electrical components. Fuel, air, compression, and spark. Any one of these things could cause your engine not to start.
I'm not trying to downplay or criticize just reminding you there are more things to look at.
Next time you post I'll try to reply within seconds.;)J/king
 

whenfoxforks-ruled

Old MX Racer
~SPONSOR~
Oct 19, 2006
8,129
2
Merrillville,Indiana
As long as your stator plate is lined up,your key is not sheared and you are trying a new plug after it dies,then I would check the plug for jetting or mechanical issues.
 

MXer666

Member
Jul 15, 2007
75
0
its just really bugging me, i dont know what it is. Since i got the bike it had always had a weak spark and now that i had my new stator put on it had a big spark for one day. Ive replaced everything except the flywheel and the pulse generator with good working units, ive made sure all grounds are good. I have a buddy with the same bike and he got the same stator as me and he didnt have to time his bike. I checked my reeds and there firmly pressed against the reed cage with no cracks or missing pieces, ive got just about 180PSI of compression my air filter is a bit dirty but no enough to stop the bike from working properly(the air filter has about 1.5 hours of time since it was last cleaned)

Its just really getting to me cuz usually i know what the problem of something is when i hear a story or someone comes to me with advice but this.... this i have no idea! Does anyone know where i can get a new flywheel? that might be my cause but im sure as hell not paying Hondas price, if it is still availble.

What about pulse generators.... anyone know of a retailer that sells new or used pulse generators???

Thanks for the help, appreciate it.
 

MXer666

Member
Jul 15, 2007
75
0
the top end is only a few hours old, probably like 10. its a rough guess but im anal about top ends. the plug is wet and by dark i dont know what u mean. its not oil fouled dark. Ive tried new spark plugs, 4 new ones to make sure i wasnt getting faulty ones.
 

MXer666

Member
Jul 15, 2007
75
0
what do you mean "can I" do you mean can i personally or can you do a leak down test of the bottom end? I can personally do a leak down test but i dont think that will be of any use cuz ive replaced all seals and gaskets and they all have the same time as my top end.
 

MXer666

Member
Jul 15, 2007
75
0
well guys i think i might have solved my problem.......... How close is a pulse generator sapossed to be to the flywheel?? is it like a hairline? Cuz i moved mine closer to my flywheel and used the new iridium plug i baught today(thinner electrode, thaught it might make the spark more concentrated) and put it in the cap and kicked it over it looks really good so i took my bike out and tried to start it. Again no dice......... so i thaught it was flooded and i was right. I turned the bike upside down and gas poured out the cylinder and out my airbox.

so i havnt had the chance to try to start my bike now that its unflooded cuz the air filter was covered in gas and i have to clean it and let it dry and re oil it so ill fill you in tommorow on how it turns out.
 
Top Bottom