What am I missing here??

Joined
Dec 12, 2002
Messages
83
Likes
0
#1
Just did my first ever top end and the bike is running great during break in, BUT..I had the bike sitting for a couple years with gas in the carb ( :whoa: ) so I cleaned out the carb, all the jets, float needle, etc. Put turned the fuel on and fuel came pouring out the overflow tube. Bike ran fine otherwise.

Took the carb back apart and there was still some gooey crud stuck to the top of the float needle. So, I cleaned it out and could see the passage clearly where the needle goes in. Made sure the needle was very clean and the rubber surface on the tip is still smooth. Added an inline filter to prevent any left over bits of gunk from the tank getting in.....BUT, it still pours out the overflow tube.

The bike runs great otherwise, what am I missing?? :yell:
 
Joined
Dec 6, 2005
Messages
340
Likes
0
#2
The tang on your float that holds the needle is bent too far up, when the bowl fills, the float goes up and the tang pushes the needle down to stop the gas from entering the carb. when it's adjusted too far up, the needle never seats and gas runs out the overflow tube.
 
Joined
Dec 12, 2002
Messages
83
Likes
0
#3
I'll try adjusting that. I just figured since it never did it before that the float was adjusted OK. I should see if I have any clear tubing and I can set it properly. Is it the same as on my road bike? I use clear tubing and open the valve at the bottom of the float bowl and hold the tubing up along side the carb and see where the level is?

Or is there an easier way?
 
Joined
Feb 4, 2005
Messages
45
Likes
0
#4
Clean Needle Seat?

Use a Q-tip with carb cleaner on it to clean the float needle seat down in the hole where the needle fits into.